install-eg.sh: Use latest upgrade branch; specify EG version; do not install web...
authorJeff Davis <jdavis@sitka.bclibraries.ca>
Mon, 22 Jun 2015 22:05:14 +0000 (15:05 -0700)
committerJeff Davis <jdavis@sitka.bclibraries.ca>
Mon, 22 Jun 2015 22:05:14 +0000 (15:05 -0700)
Signed-off-by: Jeff Davis <jdavis@sitka.bclibraries.ca>
deployment/install-eg.sh

index 2c6fb9a..3c33bd6 100755 (executable)
@@ -8,9 +8,10 @@ HOMEDIR="/home/${DEFAULT_USER}"
 #BUILDDIR="${HOMEDIR}/${EGRELEASE}"
 BUILDDIR="${HOMEDIR}/evergreen"
 INSTALLDIR="/srv/openils"
-BRANCH="upgrade/eg28/phase2b-tpac"
+BRANCH="upgrade/eg28/phase3-tpac"
 STAMP_ID="rel_2_8_1"
 ALT_STAMP_IDS="2_8_1 rel_2_8_beta 2_8_beta rel_2_8_0 2_8_0"
+VERSION="2.8.1.sitka.0"
 SITKACONF="${HOMEDIR}/sysadmin"
 SITKATOOLS="/root/sitka-tools"
 
@@ -41,7 +42,7 @@ suwrap "cd ${BUILDDIR} && git fetch origin && git checkout ${BRANCH} && git pull
  
 # as root
 cd ${BUILDDIR} && make -f Open-ILS/src/extras/Makefile.install ubuntu-trusty
-cd ${BUILDDIR} && make -f Open-ILS/src/extras/Makefile.install ubuntu-trusty-developer # required for web client
+#cd ${BUILDDIR} && make -f Open-ILS/src/extras/Makefile.install ubuntu-trusty-developer # required for web client
 # by default, CPAN needs some manual input at this point; you can just accept all defaults
  
 # as DEFAULT_USER
@@ -51,7 +52,7 @@ suwrap "cd ${BUILDDIR} && make" ${DEFAULT_USER}
 suwrap "cd ${BUILDDIR}/build/i18n && make LOCALE=fr-CA install && make LOCALE=en-CA install" ${DEFAULT_USER}
  
 # as root
-cd ${BUILDDIR} && make STAFF_CLIENT_STAMP_ID=${STAMP_ID} install
+cd ${BUILDDIR} && make STAFF_CLIENT_VERSION=${VERSION} STAFF_CLIENT_STAMP_ID=${STAMP_ID} install
 mv ${INSTALLDIR}/var/web/reports/fm_IDL.xml ${INSTALLDIR}/var/web/reports/fm_IDL.xml.orig && cp ${INSTALLDIR}/conf/fm_IDL.xml ${INSTALLDIR}/var/web/reports/
 chown -R opensrf:opensrf ${INSTALLDIR}